ScoutRealtime installed

Scout Realtime

Just installed ScoutRealtime on my server, and the result looks awesome!

When installing, I ran into a common error:

/vendor_ruby/1.8/rubygems/custom_require.rb:36:in 'gem_original_require': no such file to load -- json (LoadError) .....

which got me really confused, since I don't use Ruby at all.

The error is complaining about the missing json gem. But to solve the problem, I had to install RVM with the Ruby that already existed in my Ubuntu (or I accidentally installed at one point) by running the line:

\curl -sSL https://get.rvm.io | bash -s stable

and then:

source /home/neil/.rvm/scripts/rvm

finally run the following:

rvm install 2.1.1
rvm use 2.1.1
gem install json
gem install scout_realtime

and it works!

discussion on hackernews

comments powered by Disqus